Improper Input Validation Affecting unity-settings-daemon package, versions <15.04.1+15.04.20150408-0ubuntu1.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.37% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1504-UNITYSETTINGSDAEMON-262171
  • published17 Sept 2015
  • disclosed17 Sept 2015

Introduced: 17 Sep 2015

CVE-2015-1319  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:15.04 unity-settings-daemon to version 15.04.1+15.04.20150408-0ubuntu1.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream unity-settings-daemon package and not the unity-settings-daemon package as distributed by Ubuntu. See How to fix? for Ubuntu:15.04 relevant fixed versions and status.

The Unity Settings Daemon before 14.04.0+14.04.20150825-0ubuntu2 and 15.04.x before 15.04.1+15.04.20150408-0ubuntu1.2 does not properly detect if the screen is locked, which allows physically proximate attackers to mount removable media while the screen is locked as demonstrated by inserting a USB thumb drive.

CVSS Base Scores

version 3.1