Numeric Errors Affecting xmltooling package, versions <1.5.3-2+deb8u1build0.15.04.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.44% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1504-XMLTOOLING-299661
  • published12 Aug 2015
  • disclosed12 Aug 2015

Introduced: 12 Aug 2015

CVE-2015-0851  (opens in a new tab)
CWE-189  (opens in a new tab)

How to fix?

Upgrade Ubuntu:15.04 xmltooling to version 1.5.3-2+deb8u1build0.15.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream xmltooling package and not the xmltooling package as distributed by Ubuntu. See How to fix? for Ubuntu:15.04 relevant fixed versions and status.

XMLTooling-C before 1.5.5, as used in OpenSAML-C and Shibboleth Service Provider (SP), does not properly handle integer conversion exceptions, which allows remote attackers to cause a denial of service (crash) via schema-invalid XML data.

CVSS Base Scores

version 3.1