Information Exposure Affecting libgcrypt20 package, versions <1.6.3-2ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.43% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1510-LIBGCRYPT20-391851
  • published19 Apr 2016
  • disclosed19 Apr 2016

Introduced: 19 Apr 2016

CVE-2015-7511  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:15.10 libgcrypt20 to version 1.6.3-2ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgcrypt20 package and not the libgcrypt20 package as distributed by Ubuntu. See How to fix? for Ubuntu:15.10 relevant fixed versions and status.

Libgcrypt before 1.6.5 does not properly perform elliptic-point curve multiplication during decryption, which makes it easier for physically proximate attackers to extract ECDH keys by measuring electromagnetic emanations.

CVSS Base Scores

version 3.1