CVE-2016-2175 Affecting libpdfbox-java package, versions <1:1.8.7+dfsg-1+deb8u1build0.15.10.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.84% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1510-LIBPDFBOXJAVA-277484
  • published1 Jun 2016
  • disclosed1 Jun 2016

Introduced: 1 Jun 2016

CVE-2016-2175  (opens in a new tab)

How to fix?

Upgrade Ubuntu:15.10 libpdfbox-java to version 1:1.8.7+dfsg-1+deb8u1build0.15.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libpdfbox-java package and not the libpdfbox-java package as distributed by Ubuntu. See How to fix? for Ubuntu:15.10 relevant fixed versions and status.

Apache PDFBox before 1.8.12 and 2.x before 2.0.1 does not properly initialize the XML parsers, which allows context-dependent attackers to conduct XML External Entity (XXE) attacks via a crafted PDF.