Access Restriction Bypass Affecting lxcfs package, versions <0.10-0ubuntu2.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.38% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1510-LXCFS-266169
  • published7 Dec 2015
  • disclosed7 Dec 2015

Introduced: 7 Dec 2015

CVE-2015-1344  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Ubuntu:15.10 lxcfs to version 0.10-0ubuntu2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lxcfs package and not the lxcfs package as distributed by Ubuntu. See How to fix? for Ubuntu:15.10 relevant fixed versions and status.

The do_write_pids function in lxcfs.c in LXCFS before 0.12 does not properly check permissions, which allows local users to gain privileges by writing a pid to the tasks file.

CVSS Base Scores

version 3.1