Improper Access Control Affecting lxd package, versions <0.20-0ubuntu4.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.3% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1510-LXD-277900
  • published9 Jun 2016
  • disclosed9 Jun 2016

Introduced: 9 Jun 2016

CVE-2016-1581  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade Ubuntu:15.10 lxd to version 0.20-0ubuntu4.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lxd package and not the lxd package as distributed by Ubuntu. See How to fix? for Ubuntu:15.10 relevant fixed versions and status.

LXD before 2.0.2 uses world-readable permissions for /var/lib/lxd/zfs.img when setting up a loop based ZFS pool, which allows local users to copy and read data from arbitrary containers via unspecified vectors.