Information Exposure Affecting tomcat7 package, versions <7.0.64-1ubuntu0.3


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
6.23% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1510-TOMCAT7-364050
  • published25 Feb 2016
  • disclosed25 Feb 2016

Introduced: 25 Feb 2016

CVE-2016-0706  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:15.10 tomcat7 to version 7.0.64-1ubuntu0.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tomcat7 package and not the tomcat7 package as distributed by Ubuntu. See How to fix? for Ubuntu:15.10 relevant fixed versions and status.

Apache Tomcat 6.x before 6.0.45, 7.x before 7.0.68, 8.x before 8.0.31, and 9.x before 9.0.0.M2 does not place org.apache.catalina.manager.StatusManagerServlet on the org/apache/catalina/core/RestrictedServlets.properties list, which allows remote authenticated users to bypass intended SecurityManager restrictions and read arbitrary HTTP requests, and consequently discover session ID values, via a crafted web application.

References