Improper Input Validation The advisory has been revoked - it doesn't affect any version of package apache-log4j2  (opens in a new tab)


Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
100% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-APACHELOG4J2-3252124
  • published20 Dec 2021
  • disclosed18 Dec 2021

Introduced: 18 Dec 2021

CVE-2021-45105  (opens in a new tab)
CWE-20  (opens in a new tab)
CWE-674  (opens in a new tab)

Amendment

The Ubuntu security team deemed this advisory irrelevant for Ubuntu:16.04.

NVD Description

Note: Versions mentioned in the description apply only to the upstream apache-log4j2 package and not the apache-log4j2 package as distributed by Ubuntu.

Apache Log4j2 versions 2.0-alpha1 through 2.16.0 (excluding 2.12.3 and 2.3.1) did not protect from uncontrolled recursion from self-referential lookups. This allows an attacker with control over Thread Context Map data to cause a denial of service when a crafted string is interpreted. This issue was fixed in Log4j 2.17.0, 2.12.3, and 2.3.1.