OS Command Injection Affecting ark package, versions <4:15.12.3-0ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.12% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-ARK-320266
  • published27 Mar 2017
  • disclosed27 Mar 2017

Introduced: 27 Mar 2017

CVE-2017-5330  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 ark to version 4:15.12.3-0ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ark package and not the ark package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

ark before 16.12.1 might allow remote attackers to execute arbitrary code via an executable in an archive, related to associated applications.