Arbitrary Code Injection Affecting evolution-data-server package, versions <3.18.5-1ubuntu1.3


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.81% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-EVOLUTIONDATASERVER-575476
  • published7 Jul 2020
  • disclosed17 Jul 2020

Introduced: 7 Jul 2020

CVE-2020-14928  (opens in a new tab)
CWE-74  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 evolution-data-server to version 3.18.5-1ubuntu1.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream evolution-data-server package and not the evolution-data-server package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

evolution-data-server (eds) through 3.36.3 has a STARTTLS buffering issue that affects SMTP and POP3. When a server sends a "begin TLS" response, eds reads additional data and evaluates it in a TLS context, aka "response injection."

CVSS Base Scores

version 3.1