Use After Free Affecting exempi package, versions <2.2.2-2ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.65% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-EXEMPI-296949
  • published15 Mar 2018
  • disclosed15 Mar 2018

Introduced: 15 Mar 2018

CVE-2017-18234  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 exempi to version 2.2.2-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream exempi package and not the exempi package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

An issue was discovered in Exempi before 2.4.3. It allows remote attackers to cause a denial of service (invalid memcpy with resultant use-after-free) or possibly have unspecified other impact via a .pdf file containing JPEG data, related to XMPFiles/source/FormatSupport/ReconcileTIFF.cpp, XMPFiles/source/FormatSupport/TIFF_MemoryReader.cpp, and XMPFiles/source/FormatSupport/TIFF_Support.hpp.