Arbitrary Command Injection Affecting extplorer package, versions <2.1.0b6+dfsg.3-4+deb7u5ubuntu0.16.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.17% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-EXTPLORER-300403
  • published9 Aug 2017
  • disclosed9 Aug 2017

Introduced: 9 Aug 2017

CVE-2017-12756  (opens in a new tab)
CWE-77  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 extplorer to version 2.1.0b6+dfsg.3-4+deb7u5ubuntu0.16.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream extplorer package and not the extplorer package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Command inject in transfer from another server in extplorer 2.1.9 and prior allows attacker to inject command via the userfile[0] parameter.