Improper Authorization Affecting freeipa package, versions <4.3.1-0ubuntu1+esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.8% (57th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-FREEIPA-370028
  • published13 Mar 2018
  • disclosed13 Mar 2018

Introduced: 13 Mar 2018

CVE-2016-9575  (opens in a new tab)
CWE-285  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 freeipa to version 4.3.1-0ubuntu1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream freeipa package and not the freeipa package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Ipa versions 4.2.x, 4.3.x before 4.3.3 and 4.4.x before 4.4.3 did not properly check the user's permissions while modifying certificate profiles in IdM's certprofile-mod command. An authenticated, unprivileged attacker could use this flaw to modify profiles to issue certificates with arbitrary naming or key usage information and subsequently use such certificates for other attacks.