Improper Access Control Affecting freeipa package, versions <4.3.1-0ubuntu1+esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.61% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-FREEIPA-370030
  • published7 Sept 2016
  • disclosed7 Sept 2016

Introduced: 7 Sep 2016

CVE-2016-5404  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 freeipa to version 4.3.1-0ubuntu1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream freeipa package and not the freeipa package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

The cert_revoke command in FreeIPA does not check for the "revoke certificate" permission, which allows remote authenticated users to revoke arbitrary certificates by leveraging the "retrieve certificate" permission.