Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) Affecting gcc-5 package, versions <5.4.0-6ubuntu1~16.04.12+esm2


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.47% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-GCC5-1214286
  • published10 Sept 2020
  • disclosed26 Jul 2017

Introduced: 26 Jul 2017

CVE-2017-11671  (opens in a new tab)
CWE-338  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 gcc-5 to version 5.4.0-6ubuntu1~16.04.12+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gcc-5 package and not the gcc-5 package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Under certain circumstances, the ix86_expand_builtin function in i386.c in GNU Compiler Collection (GCC) version 4.6, 4.7, 4.8, 4.9, 5 before 5.5, and 6 before 6.4 will generate instruction sequences that clobber the status flag of the RDRAND and RDSEED intrinsics before it can be read, potentially causing failures of these instructions to go unreported. This could potentially lead to less randomness in random number generation.