Memory Leak Affecting giflib package, versions <5.1.4-0.3~16.04.1+esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.72% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-GIFLIB-2928790
  • published16 Jun 2022
  • disclosed14 Jun 2022

Introduced: 14 Jun 2022

CVE-2021-40633  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 giflib to version 5.1.4-0.3~16.04.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream giflib package and not the giflib package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

A memory leak (out-of-memory) in gif2rgb in util/gif2rgb.c in giflib 5.1.4 allows remote attackers trigger an out of memory exception or denial of service via a gif format file.

CVSS Base Scores

version 3.1