Double Free Affecting gnuplot package, versions <4.6.6-3ubuntu0.1+esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.57% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-GNUPLOT-1137200
  • published20 Jun 2025
  • disclosed16 Sept 2020

Introduced: 16 Sep 2020

CVE-2020-25559  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 gnuplot to version 4.6.6-3ubuntu0.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnuplot package and not the gnuplot package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

gnuplot 5.5 is affected by double free when executing print_set_output. This may result in context-dependent arbitrary code execution.

CVSS Base Scores

version 3.1