Buffer Overflow Affecting graphviz package, versions <2.38.0-12ubuntu2.1+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.61% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-GRAPHVIZ-1617401
  • published16 Feb 2022
  • disclosed29 Apr 2021

Introduced: 29 Apr 2021

CVE-2020-18032  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 graphviz to version 2.38.0-12ubuntu2.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream graphviz package and not the graphviz package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Buffer Overflow in Graphviz Graph Visualization Tools from commit ID f8b9e035 and earlier allows remote attackers to execute arbitrary code or cause a denial of service (application crash) by loading a crafted file into the "lib/common/shapes.c" component.

CVSS Base Scores

version 3.1