Out-of-bounds Read Affecting gst-plugins-base1.0 package, versions <1.8.3-1ubuntu0.3+esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
5.37% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-GSTPLUGINSBASE10-1298776
  • published8 May 2021
  • disclosed2 Jun 2021

Introduced: 8 May 2021

CVE-2021-3522  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 gst-plugins-base1.0 to version 1.8.3-1ubuntu0.3+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gst-plugins-base1.0 package and not the gst-plugins-base1.0 package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

GStreamer before 1.18.4 may perform an out-of-bounds read when handling certain ID3v2 tags.

CVSS Base Scores

version 3.1