Improper Input Validation Affecting ibm-java80 package, versions <8.0.5.22-0ubuntu1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.93% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-IBMJAVA80-262634
  • published2 Dec 2018
  • disclosed20 Aug 2018

Introduced: 20 Aug 2018

CVE-2018-1517  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 ibm-java80 to version 8.0.5.22-0ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ibm-java80 package and not the ibm-java80 package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

A flaw in the java.math component in IBM SDK, Java Technology Edition 6.0, 7.0, and 8.0 may allow an attacker to inflict a denial-of-service attack with specially crafted String data. IBM X-Force ID: 141681.