Information Exposure Affecting ironic package, versions <1:5.1.2-0ubuntu1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.86% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-IRONIC-274244
  • published12 Jul 2016
  • disclosed12 Jul 2016

Introduced: 12 Jul 2016

CVE-2016-4985  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 ironic to version 1:5.1.2-0ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ironic package and not the ironic package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

The ironic-api service in OpenStack Ironic before 4.2.5 (Liberty) and 5.x before 5.1.2 (Mitaka) allows remote attackers to obtain sensitive information about a registered node by leveraging knowledge of the MAC address of a network card belonging to that node and sending a crafted POST request to the v1/drivers/$DRIVER_NAME/vendor_passthru resource.