Use of Externally-Controlled Format String Affecting irssi package, versions <0.8.19-1ubuntu1.6


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.91% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-IRSSI-350758
  • published6 Jan 2018
  • disclosed6 Jan 2018

Introduced: 6 Jan 2018

CVE-2018-5207  (opens in a new tab)
CWE-134  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 irssi to version 0.8.19-1ubuntu1.6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream irssi package and not the irssi package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

When using an incomplete variable argument, Irssi before 1.0.6 may access data beyond the end of the string.