Use After Free Affecting irssi package, versions <0.8.19-1ubuntu1.8


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.54% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-IRSSI-350774
  • published9 Jan 2019
  • disclosed9 Jan 2019

Introduced: 9 Jan 2019

CVE-2019-5882  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 irssi to version 0.8.19-1ubuntu1.8 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream irssi package and not the irssi package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Irssi 1.1.x before 1.1.2 has a use after free when hidden lines are expired from the scroll buffer.