Use After Free Affecting irssi package, versions <0.8.19-1ubuntu1.3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.95% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-IRSSI-350852
  • published3 Mar 2017
  • disclosed3 Mar 2017

Introduced: 3 Mar 2017

CVE-2017-5194  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 irssi to version 0.8.19-1ubuntu1.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream irssi package and not the irssi package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Use-after-free vulnerability in Irssi before 0.8.21 allows remote attackers to cause a denial of service (crash) via an invalid nick message.