Use After Free Affecting irssi package, versions <0.8.19-1ubuntu1.9


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.36% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-IRSSI-453087
  • published29 Jun 2019
  • disclosed29 Jun 2019

Introduced: 29 Jun 2019

CVE-2019-13045  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 irssi to version 0.8.19-1ubuntu1.9 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream irssi package and not the irssi package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Irssi before 1.0.8, 1.1.x before 1.1.3, and 1.2.x before 1.2.1, when SASL is enabled, has a use after free when sending SASL login to the server.