Out-of-bounds Write Affecting jbig2dec package, versions <0.12+20150918-1ubuntu0.1+esm2


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.74% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-JBIG2DEC-1147320
  • published10 Sept 2020
  • disclosed27 Apr 2020

Introduced: 27 Apr 2020

CVE-2020-12268  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 jbig2dec to version 0.12+20150918-1ubuntu0.1+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream jbig2dec package and not the jbig2dec package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

jbig2_image_compose in jbig2_image.c in Artifex jbig2dec before 0.18 has a heap-based buffer overflow.

CVSS Base Scores

version 3.1