Out-of-Bounds Affecting jbig2dec package, versions <0.12+20150918-1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.51% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-JBIG2DEC-308510
  • published24 Apr 2018
  • disclosed24 Apr 2018

Introduced: 24 Apr 2018

CVE-2016-8729  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 jbig2dec to version 0.12+20150918-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream jbig2dec package and not the jbig2dec package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

An exploitable memory corruption vulnerability exists in the JBIG2 parser of Artifex MuPDF 1.9. A specially crafted PDF can cause a negative number to be passed to a memset resulting in memory corruption and potential code execution. An attacker can specially craft a PDF and send to the victim to trigger this vulnerability.

CVSS Base Scores

version 3.1