Information Exposure Affecting kinit package, versions <5.18.0-0ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.4% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-KINIT-264969
  • published13 Jul 2016
  • disclosed13 Jul 2016

Introduced: 13 Jul 2016

CVE-2016-3100  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 kinit to version 5.18.0-0ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kinit package and not the kinit package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

kinit in KDE Frameworks before 5.23.0 uses weak permissions (644) for /tmp/xauth-xxx-_y, which allows local users to obtain X11 cookies of other users and consequently capture keystrokes and possibly gain privileges by reading the file.