Improper Input Validation Affecting lftp package, versions <4.6.3a-1ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.78% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-LFTP-320194
  • published1 Aug 2018
  • disclosed1 Aug 2018

Introduced: 1 Aug 2018

CVE-2018-10916  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 lftp to version 4.6.3a-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lftp package and not the lftp package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

It has been discovered that lftp up to and including version 4.8.3 does not properly sanitize remote file names, leading to a loss of integrity on the local system when reverse mirroring is used. A remote attacker may trick a user to use reverse mirroring on an attacker controlled FTP server, resulting in the removal of all files in the current working directory of the victim's system.