NULL Pointer Dereference Affecting libextractor package, versions <1:1.3-4+deb9u3build0.16.04.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.23% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-LIBEXTRACTOR-313483
  • published24 Dec 2018
  • disclosed24 Dec 2018

Introduced: 24 Dec 2018

CVE-2018-20431  (opens in a new tab)
CWE-476  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 libextractor to version 1:1.3-4+deb9u3build0.16.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libextractor package and not the libextractor package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

GNU Libextractor through 1.8 has a NULL Pointer Dereference vulnerability in the function process_metadata() in plugins/ole2_extractor.c.