Memory Leak Affecting libhtp package, versions <0.5.15-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.5% (43rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-LIBHTP-13505126
  • published12 Oct 2025
  • disclosed23 Jul 2025

Introduced: 23 Jul 2025

CVE-2025-53537  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 libhtp to version 0.5.15-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libhtp package and not the libhtp package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

LibHTP is a security-aware parser for the HTTP protocol and its related bits and pieces. In versions 0.5.50 and below, there is a traffic-induced memory leak that can starve the process of memory, leading to loss of visibility. To workaround this issue, set suricata.yaml app-layer.protocols.http.libhtp.default-config.lzma-enabled to false. This issue is fixed in version 0.5.51.