Out-of-bounds Read Affecting libidn package, versions <1.32-3ubuntu1.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
6.72% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-LIBIDN-310975
  • published7 Sept 2016
  • disclosed7 Sept 2016

Introduced: 7 Sep 2016

CVE-2015-8948  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 libidn to version 1.32-3ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libidn package and not the libidn package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

idn in GNU libidn before 1.33 might allow remote attackers to obtain sensitive memory information by reading a zero byte as input, which triggers an out-of-bounds read.