Out-of-bounds Write Affecting libmediainfo package, versions <0.7.82-1ubuntu0.1~esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.87% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-LIBMEDIAINFO-2342631
  • published19 Aug 2025
  • disclosed18 Mar 2021

Introduced: 18 Mar 2021

CVE-2020-26797  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 libmediainfo to version 0.7.82-1ubuntu0.1~esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libmediainfo package and not the libmediainfo package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Mediainfo before version 20.08 has a heap buffer overflow vulnerability via MediaInfoLib::File_Gxf::ChooseParser_ChannelGrouping.

CVSS Base Scores

version 3.1