Improper Input Validation Affecting libowasp-esapi-java package, versions <2.1.0-2ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.5% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-LIBOWASPESAPIJAVA-10769020
  • published17 Apr 2026
  • disclosed29 Jun 2025

Introduced: 29 Jun 2025

CVE-2025-5878  (opens in a new tab)
CWE-20  (opens in a new tab)
CWE-138  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 libowasp-esapi-java to version 2.1.0-2ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libowasp-esapi-java package and not the libowasp-esapi-java package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

A vulnerability was found in ESAPI esapi-java-legacy and classified as problematic. This issue affects the interface Encoder.encodeForSQL of the SQL Injection Defense. An attack leads to an improper neutralization of special elements. The attack may be initiated remotely and an exploit has been disclosed to the public. The project was contacted early about this issue and handled it with an exceptional level of professionalism. Upgrading to version 2.7.0.0 is able to address this issue. Commit ID f75ac2c2647a81d2cfbdc9c899f8719c240ed512 is disabling the feature by default and any attempt to use it will trigger a warning. And commit ID e2322914304d9b1c52523ff24be495b7832f6a56 is updating the misleading Java class documentation to warn about the risks.

CVSS Base Scores

version 3.1