Resource Exhaustion Affecting libraw package, versions <0.17.1-1ubuntu0.5


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.93% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-LIBRAW-346751
  • published23 Dec 2018
  • disclosed20 Feb 2019

Introduced: 23 Dec 2018

CVE-2018-5819  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 libraw to version 0.17.1-1ubuntu0.5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libraw package and not the libraw package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

An error within the "parse_sinar_ia()" function (internal/dcraw_common.cpp) within LibRaw versions prior to 0.19.1 can be exploited to exhaust available CPU resources.