Improper Validation of Specified Quantity in Input Affecting libraw package, versions <0.17.1-1ubuntu0.5+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.42% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-LIBRAW-9828167
  • published7 May 2025
  • disclosed21 Apr 2025

Introduced: 21 Apr 2025

CVE-2025-43964  (opens in a new tab)
CWE-1284  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 libraw to version 0.17.1-1ubuntu0.5+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libraw package and not the libraw package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

In LibRaw before 0.21.4, tag 0x412 processing in phase_one_correct in decoders/load_mfbacks.cpp does not enforce minimum w0 and w1 values.

CVSS Base Scores

version 3.1