Out-of-bounds Write Affecting libsdl1.2 package, versions <1.2.15+dfsg1-3ubuntu0.1+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.06% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-LIBSDL12-2441632
  • published6 Apr 2022
  • disclosed1 Apr 2022

Introduced: 1 Apr 2022

CVE-2021-33657  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 libsdl1.2 to version 1.2.15+dfsg1-3ubuntu0.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsdl1.2 package and not the libsdl1.2 package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

There is a heap overflow problem in video/SDL_pixels.c in SDL (Simple DirectMedia Layer) 2.x to 2.0.18 versions. By crafting a malicious .BMP file, an attacker can cause the application using this library to crash, denial of service or Code execution.

CVSS Base Scores

version 3.1