Out-of-bounds Write Affecting libsdl1.2 package, versions <1.2.15+dfsg1-3ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.1% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-LIBSDL12-455640
  • published8 Feb 2019
  • disclosed8 Feb 2019

Introduced: 8 Feb 2019

CVE-2019-7637  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 libsdl1.2 to version 1.2.15+dfsg1-3ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsdl1.2 package and not the libsdl1.2 package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

SDL (Simple DirectMedia Layer) through 1.2.15 and 2.x through 2.0.9 has a heap-based buffer overflow in SDL_FillRect in video/SDL_surface.c.

CVSS Base Scores

version 3.1