Improper Input Validation Affecting libtomcrypt package, versions <1.17-7ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.78% (51st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-LIBTOMCRYPT-264946
  • published13 Feb 2017
  • disclosed13 Feb 2017

Introduced: 13 Feb 2017

CVE-2016-6129  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 libtomcrypt to version 1.17-7ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libtomcrypt package and not the libtomcrypt package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

The rsa_verify_hash_ex function in rsa_verify_hash.c in LibTomCrypt, as used in OP-TEE before 2.2.0, does not validate that the message length is equal to the ASN.1 encoded data length, which makes it easier for remote attackers to forge RSA signatures or public certificates by leveraging a Bleichenbacher signature forgery attack.

CVSS Base Scores

version 3.1