Out-of-Bounds Affecting libxcursor package, versions <1:1.1.14-1ubuntu0.16.04.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
5.68% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-LIBXCURSOR-282545
  • published1 Aug 2018
  • disclosed1 Aug 2018

Introduced: 1 Aug 2018

CVE-2015-9262  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 libxcursor to version 1:1.1.14-1ubuntu0.16.04.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxcursor package and not the libxcursor package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

_XcursorThemeInherits in library.c in libXcursor before 1.1.15 allows remote attackers to cause denial of service or potentially code execution via a one-byte heap overflow.