Improper Restriction of Excessive Authentication Attempts Affecting mailman package, versions <1:2.1.20-1ubuntu0.6+esm1


Severity

Recommended
high

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.25% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-MAILMAN-1766337
  • published22 Oct 2021
  • disclosed21 Oct 2021

Introduced: 21 Oct 2021

CVE-2021-42096  (opens in a new tab)
CWE-307  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 mailman to version 1:2.1.20-1ubuntu0.6+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mailman package and not the mailman package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

GNU Mailman before 2.1.35 may allow remote Privilege Escalation. A certain csrf_token value is derived from the admin password, and may be useful in conducting a brute-force attack against that password.

CVSS Base Scores

version 3.1