Cross-site Request Forgery (CSRF) Affecting mailman package, versions <1:2.1.20-1ubuntu0.6+esm3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.76% (54th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-MAILMAN-2309767
  • published4 Dec 2021
  • disclosed2 Dec 2021

Introduced: 2 Dec 2021

CVE-2021-44227  (opens in a new tab)
CWE-352  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 mailman to version 1:2.1.20-1ubuntu0.6+esm3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mailman package and not the mailman package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

In GNU Mailman before 2.1.38, a list member or moderator can get a CSRF token and craft an admin request (using that token) to set a new admin password or make other changes.

CVSS Base Scores

version 3.1