Arbitrary Code Injection Affecting mailman package, versions <1:2.1.20-1ubuntu0.5


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.7% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-MAILMAN-568562
  • published6 May 2020
  • disclosed6 May 2020

Introduced: 6 May 2020

CVE-2020-12108  (opens in a new tab)
CWE-74  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 mailman to version 1:2.1.20-1ubuntu0.5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mailman package and not the mailman package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

/options/mailman in GNU Mailman before 2.1.31 allows Arbitrary Content Injection.

CVSS Base Scores

version 3.1