Out-of-bounds Write Affecting milkytracker package, versions <0.90.85+dfsg-2.2+deb8u1build0.16.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.39% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-MILKYTRACKER-456408
  • published2 Aug 2019
  • disclosed1 Aug 2019

Introduced: 1 Aug 2019

CVE-2019-14497  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 milkytracker to version 0.90.85+dfsg-2.2+deb8u1build0.16.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream milkytracker package and not the milkytracker package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

ModuleEditor::convertInstrument in tracker/ModuleEditor.cpp in MilkyTracker 1.02.00 has a heap-based buffer overflow.

CVSS Base Scores

version 3.1