Out-of-Bounds Affecting miniupnpd package, versions <1.8.20140523-4.1+deb9u1build0.16.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.47% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-MINIUPNPD-296853
  • published3 Jan 2018
  • disclosed3 Jan 2018

Introduced: 3 Jan 2018

CVE-2017-1000494  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 miniupnpd to version 1.8.20140523-4.1+deb9u1build0.16.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream miniupnpd package and not the miniupnpd package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Uninitialized stack variable vulnerability in NameValueParserEndElt (upnpreplyparse.c) in miniupnpd < 2.0 allows an attacker to cause Denial of Service (Segmentation fault and Memory Corruption) or possibly have unspecified other impact