Cross-site Request Forgery (CSRF) Affecting monit package, versions <1:5.16-2ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.88% (58th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-MONIT-285642
  • published27 Jun 2018
  • disclosed10 Sept 2018

Introduced: 27 Jun 2018

CVE-2016-7067  (opens in a new tab)
CWE-352  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 monit to version 1:5.16-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream monit package and not the monit package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Monit before version 5.20.0 is vulnerable to a cross site request forgery attack. Successful exploitation will enable an attacker to disable/enable all monitoring for a particular host or disable/enable monitoring for a specific service.