Incorrect Authorization Affecting monit package, versions <1:5.16-2ubuntu0.2+esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.89% (56th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-MONIT-5786675
  • published19 Aug 2025
  • disclosed18 Jul 2023

Introduced: 18 Jul 2023

CVE-2022-26563  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 monit to version 1:5.16-2ubuntu0.2+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream monit package and not the monit package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

An issue was discovered in Tildeslash Monit before 5.31.0, allows remote attackers to gain escilated privlidges due to improper PAM-authorization.

CVSS Base Scores

version 3.1