Integer Overflow or Wraparound Affecting musl package, versions <1.1.9-1ubuntu0.1~esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.36% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-MUSL-291878
  • published13 Feb 2017
  • disclosed13 Feb 2017

Introduced: 13 Feb 2017

CVE-2016-8859  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 musl to version 1.1.9-1ubuntu0.1~esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream musl package and not the musl package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Multiple integer overflows in the TRE library and musl libc allow attackers to cause memory corruption via a large number of (1) states or (2) tags, which triggers an out-of-bounds write.