HTTP Request Smuggling Affecting netty-3.9 package, versions <3.9.0.Final-1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.65% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-NETTY39-1021861
  • published10 Sept 2020
  • disclosed27 Jan 2020

Introduced: 27 Jan 2020

CVE-2020-7238  (opens in a new tab)
CWE-444  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 netty-3.9 to version 3.9.0.Final-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream netty-3.9 package and not the netty-3.9 package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Netty 4.1.43.Final allows HTTP Request Smuggling because it mishandles Transfer-Encoding whitespace (such as a [space]Transfer-Encoding:chunked line) and a later Content-Length header. This issue exists because of an incomplete fix for CVE-2019-16869.

References

CVSS Base Scores

version 3.1