Improper Cross-boundary Removal of Sensitive Data Affecting node-eventsource package, versions <0.1.6-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.86% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-NODEEVENTSOURCE-10285082
  • published1 Jun 2025
  • disclosed12 May 2022

Introduced: 12 May 2022

CVE-2022-1650  (opens in a new tab)
CWE-212  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 node-eventsource to version 0.1.6-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-eventsource package and not the node-eventsource package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Improper Removal of Sensitive Information Before Storage or Transfer in GitHub repository eventsource/eventsource prior to v2.0.2.

CVSS Base Scores

version 3.1